FreewayTalk

6 replies to this thread. Most Recent

Neil

11 Apr 2012, 4:38 pm

[Pro] FTP error when uploading

Hi,

I’m encountering a strange error when trying to upload my site to my hosting company. The upload starts fine (the FTP details are correct) but after trying for a few seconds (about 10) the upload stops and freeway reports “cannot complete upload because the server reported an error”. It happens mainly on PDFs which get uploaded with the main site (I have a ‘downloads’ page where users can download PDFs).

So, I tried two other FTP packages instead, Cyberduck and Transmit. Both managed everything but the PDFs (the PDFs are only 1.2meg each and the file names contain no illegal characters), at which point the upload stopped - Cyberduck reporting a ‘broken pipe’ and Transmit ‘Error 135: socket write error’.

Which led me to believe there’s an issue with my net connection. My upload speed is on average 0.6meg a sec, and handles everything I throw at it everyday fine - many Gmail attachments along with my Livedrive backup which often handles gigabytes a week.

So finally I tried it with CuteFTP on Windows 7 running on the same Mac in bootcamp. Upload worked straight away, no issues. So, it’s a Mac issue then? I’m using OSX 10.7.3, MacPro 3gb Ram.

At least I know it’s not a problem attributed directly to Freeway, but thought I’d ask here in case anyone else has had the problem. If anyone can shed some light onto it I’d appreciate it.

Many thanks.

Neil.

DeltaDave

11 Apr 2012, 4:55 pm

There are different upload settings possible - try toggling between them.

They are

Automatic (default)

Passive

and Non-passive

So if you are on Auto try Passive, if that doesn’t work try Non-passive.

David

Glasgow, Scotland

iMac 27 5K El Cap and Pro Final

Neil

11 Apr 2012, 5:18 pm

Hi David,

Thanks for the reply. I forgot to mention that I’d tried all three, same error I’m afraid.

Thanks,

Neil.

DeltaDave

11 Apr 2012, 7:06 pm

In that case make sure that you save the log file and send it in to support(at)softpress.com

You will find it at

User>library>logs>Freeway 5>FTP logs

D

Glasgow, Scotland

iMac 27 5K El Cap and Pro Final

Neil

12 Apr 2012, 9:07 am

Hi Dave,

Thanks for the reply, I’ll send the log off to Softpress and see what they say.

Cheers,

Neil.

Neil

12 Apr 2012, 11:36 am

SORTED!!

Didn’t get round to sending to Softpress as I’ve just sorted it. The offending item is my LiveDrive Briefcase software, it’s a bit like Dropbox. As soon as I unmounted it from my desktop, all FTP works just fine. Given my LiveDrive Briefcase handles anything up to 3gig a day sometimes I can only asume it’s doing something with my net connection, even though I set it to pause whilst doing uploads.

So if it’s any help to anyone else, that was the problem!

Neil.

Back to Top

DeltaDave

12 Apr 2012, 5:52 pm

Glad it wasn’t a FW issue.

D

Glasgow, Scotland

iMac 27 5K El Cap and Pro Final