FreewayTalk

17 replies to this thread. Most Recent

Ian Halstead

30 Jul 2014, 2:42 pm

[Pro] Freeway 7 problems and bugs

Having just spotted and experienced the first bug, I thought it may be useful to use this thread for pointing out any others that people come across.

I get a crash when trying to drag a guide onto a master page from the left-hand ruler. I was expanding on the quick responsiveness tutorial by putting three column boxes in a container and playing with what happens at the default break-points.

I’m just about to test the horizontal ruler, and whether a complete computer restart helps. Bug output reported to Apple on the standard report that appears after a crash.

Insanity is hereditary. Your children pass it on to you.

Ian Halstead, web, graphics & artwork

http://www.ianhalstead.com

Ian Halstead

30 Jul 2014, 2:53 pm

OK… more info.

The horizontal guides can be dragged onto the page without the crash.

If I drag a guide straight onto the page paste-board and immediately drop it, it appears fine. Furthermore, I can then reposition the guide wherever I want without further incident.

It’s dragging a guide and delaying dropping it — to position it mid-way over a box width — that seems to be causing the problem. The spinning wheel of doom appears, then the crash.

More test to see how long it takes delaying the drop, before the crash occurs.

Insanity is hereditary. Your children pass it on to you.

Ian Halstead, web, graphics & artwork

http://www.ianhalstead.com

Carl Anselm

30 Jul 2014, 5:11 pm

Same here. I get a crash immediately when dragging out a guide from the left-hand ruler. The horizontal guides work well.

Somewhere in Austria

Richard van Heukelum

30 Jul 2014, 5:31 pm

I’ve just tried both horizontal and vertical guides. Both worked out fine. No issues here.

Ontwerpzaam.nl | Papendrecht, The Netherlands

Hardware: 27” iMac i5 3.1GHz / 32GB RAM / 4TB SSHD / 1GB VRAM /

Software : macOS 10.12.6 Sierra / Freeway7 (user since Freeway1)

Has moved on with CoffeeCup Software : Site Designer / Form Designer / Content Slider / Email Designer / Sonar / Website Insight and occasionally Blocs Web Design App. Use CraftCMS.

Ian Halstead

30 Jul 2014, 6:25 pm

OK… starting from a fresh boot-up, I was able to quickly drop a vertical guide onto the paste-board, and then use it as intended. The document no longer allows this — I get a crash almost immediately. Previously, any subsequent attempt resulted in the immediate crash.

It’s repeatable on demand.

Next up — I’ll try a fresh vanilla user account on the iMac, and report back.

Insanity is hereditary. Your children pass it on to you.

Ian Halstead, web, graphics & artwork

http://www.ianhalstead.com

Carl Anselm

30 Jul 2014, 6:50 pm

Tested on my second iMac with OSX 10.6.8 Freshly installed Freeway 7 No issues!

Somewhere in Austria

Joe Billings

30 Jul 2014, 6:58 pm

Thanks for spending the time, Ian. We’ll also take a look at it internally.

Joe

On 30 Jul 2014, at 19:25, Ian Halstead <[email protected]> wrote:

OK… starting from a fresh boot-up, I was able to quickly drop a vertical guide onto the paste-board, and then use it as intended. The document no longer allows this — I get a crash almost immediately. Previously, any subsequent attempt resulted in the immediate crash.

It’s repeatable on demand.

Next up — I’ll try a fresh vanilla user account on the iMac, and report back.

Joe Billings

Freeway & Exhibeo: Visual web design apps for Mac


http://www.softpress.com

Nik Andrew

30 Jul 2014, 7:55 pm

Just a note here that sometimes helps with crashes and things getting slow. Whenever I install any significant software or update onto my Mac, I generally reboot and ‘fix disc permissions’ from the recovery partition. You’d be amazed at how often problems disappear!

Nik

Carl Anselm

31 Jul 2014, 8:26 am
  • Removed all “leftovers” from previous Freeway Pro Versions (5 and 6).
  • Fixed disc permissions
  • Installed a fresh version of Freeway Pro 7 Had the same behavior as before: trying to drag a guide from the left ruler results in immediate crash.

System: Mac OSX 10.9.4 Mavericks

Somewhere in Austria

Ian Halstead

31 Jul 2014, 9:43 am

I get the same bug on the following:

Doesn’t need to be a Master page. Dragging a guide from a default page on a fresh document causes the crash.

Guest or fresh user account — still get the crash.

All the previous cases happened under Mavericks 10.9.4, Late 2013 27” iMac 3.2Ghz i5, NVIDIA GeForce GT 755M 1024 MB

Public Beta 10.10 Yosemite on above hardware — same result

Let me know if I can help in any other way Joe.

Insanity is hereditary. Your children pass it on to you.

Ian Halstead, web, graphics & artwork

http://www.ianhalstead.com

Carl Anselm

4 Aug 2014, 6:02 am

Instead of dragging out of the ruler you can use the create guides dialog. Menue->page->create guides Then rearrange it to your needs by dragging around. Hope that helps.

Somewhere in Austria

Ian Halstead

5 Aug 2014, 4:20 pm

That works well as a workaround Carl — many thanks.

Ian

Insanity is hereditary. Your children pass it on to you.

Ian Halstead, web, graphics & artwork

http://www.ianhalstead.com

Carl Anselm

5 Aug 2014, 6:02 pm

You’re welcome. I wonder if we are the only ones with this problem.

Somewhere in Austria

steve farber

10 Oct 2014, 6:39 pm

Have same issue. Any fixes yet? Running FW7Pro on MacBook Pro w/ Mavericks

Thomas Kimmich

10 Oct 2014, 7:09 pm

as far as I know - yes:

http://www.softpress.com/kb/questions/486/Freeway+7.0.1+Release+Notes

Thomas Kimmich

Kimmich DigitalMedia

http://www.kimmich-digitalmedia.com

T.+49(0)7404-914 384

Somewhere in the South of Germany

steve farber

10 Oct 2014, 7:12 pm

Thank you! Downloading the update now.

Richard van Heukelum

10 Oct 2014, 7:52 pm

Strange Freeway didn’t mention the update at startup in the first place after it’s initial release of the update?

Ontwerpzaam.nl | Papendrecht, The Netherlands

Hardware: 27” iMac i5 3.1GHz / 32GB RAM / 4TB SSHD / 1GB VRAM /

Software : macOS 10.12.6 Sierra / Freeway7 (user since Freeway1)

Has moved on with CoffeeCup Software : Site Designer / Form Designer / Content Slider / Email Designer / Sonar / Website Insight and occasionally Blocs Web Design App. Use CraftCMS.

Back to Top

Jeremy Hughes

2 Jul 2019, 8:19 pm

I’m not sure why you don’t see the red area - unless your pages are already the correct widths for the breakpoints. What happens if you start a new document and click on one of the media width tabs?

In a real document, it might be a good idea to do as much work as possible on master pages.

Jeremy

On 2 Jul 2019, at 17:37, jean enness via freewaytalk <[email protected]> wrote:

Hi

I am working on my website in Freeway 7 pro.

When I view the page in different browser sizes e.g Phone 320, Phone Landscape 480, Tablet 768, in page mode, when I press the grey tabs at the top of the page you are supposed to get a red panel up that shows you where the page is oversize so that it can be adjusted to each individual device size. Does anyone know why this is not happening ?. I am in page mode when I am doing this which seems to be correct according to the Freeway Tutorial video

Thanks Jean