FreewayTalk

5 replies to this thread. Most Recent

spidercrab

4 Dec 2014, 9:55 am

Secondsight template issues

I have just upgraded to FW7 and decided to buy a template to use as an introduction to responsive web creation with FW7. My thinking was that this could be a good introduction and also a starting point to get up and running.

I bought the Secondsight template however, it throws up some errors.

With a fresh installation FW7 and a fresh downloaded never used copy of the template, if I create a new site based on the Seconsight template, I can’t preview it or view it in a browser (Firefox or Chrome) without getting the following error:

“ACTION CANNOT BE USED. The following Actions have been incorrectly applied and will be ignored. Action: “Target Show/Hide Layer”, Page: “Home”. Action: “Target Show/Hide Layer”, Page: “Home”. Action: “Target Show/Hide Layer”, Page: “Home”.”

I then noticed a README file in the Master section and followed the instructions to install the 2 fonts required.

I tried to preview and view again but this time I get the different but similar warning: “ACTION CANNOT BE USED. The following Actions have been incorrectly applied and will be ignored. Action: “Target Show/Hide Layer”, Page: “Home”. Action: “Target Show/Hide Layer”, Page: “Home”. Action: “Target Show/Hide Layer”, Page: “Home”. Action: “Blogger Header”, Page: “Blog”. Action: “Blogger Posts”, Page: “Blog”. Action: “Blogger Archive”, Page: “Blog”. Action: “Blogger Profile”, Page: “Blog”.”

I have dealt with many of these errors over the year but I am loathe to start modifying the template to get it to work.

Can anyone shed any insight into what is going wrong here? I would expect a template to just load up without any issue although I have never used a template before.

waltd

4 Dec 2014, 12:12 pm

Is it possible that the elements to which those Actions are applied are not being generated as “Layer” elements? The error does seem to suggest that. It is possible to make a global change to a document (set the layout button to Table instead of CSS) and get this sort of result, although I have never seen it happen just by opening a document that had existing pages. Were these pages added based on the template, or were they existing in the template (was it in its default state, in other words) when you saw the error?

Walter

Freeway user since 1997

http://www.walterdavisstudio.com

spidercrab

4 Dec 2014, 2:33 pm

This is in the complete default state. I.e. Install FW7 for first time, enter serial number, add fresh downloaded template, select that template and then trying Preview or Browser produces the error.

Running OSX 10.10.1.

jay

8 May 2015, 10:35 pm

Did this get answered same issue here.

Jeremy Hughes

30 Nov 2018, 10:45 am

This came up as a support issue recently. The Blogger Actions need a web address to be set in the Upload pane of the Document Setup dialog. The Target Show/Hide Layer Action needs AppleScript support to be turned on in the Preferences dialog.

Back to Top

Jeremy Hughes

30 Nov 2018, 10:50 am

If Freeway reports Action problems when publishing, you can usually find more information by selecting a box which has the Action applied to it and opening the Actions palette. If AppleScript is turned off, and you select a box with the Show/Hide Layer Action, the Actions palette will display an error message saying “This Action requires AppleScript, which is currently disabled. You can enable this in the Preferences dialog.”

Jeremy