FreewayTalk

2 replies to this thread. Most Recent

Trey Yancy

19 Jan 2017, 9:12 pm

Display of Font Weights

This is an old one and I’ve forgotten the solution. I have a web font set up in Freeway in a number of weights, with each weight set up to display the proper display font for each weight.

It is for a responsive site with weights that vary by breakpoint but all being slender weights (light, ultralight, etc). I specified the fot weight per breakpoint in the extended tags.

Even so, the font always appears in preview and on the site as bold. I can’t remember what the fix is.

Anyone?

waltd

20 Jan 2017, 1:55 am

Each font that you set in the Freeway font settings can have its own separate screen font. It won’t affect the code that gets written, only the design interface.

Walter

On Jan 19, 2017, at 4:12 PM, Trey Yancy <[email protected]> wrote:

This is an old one and I’ve forgotten the solution. I have a web font set up in Freeway in a number of weights, with each weight set up to display the proper display font for each weight.

It is for a responsive site with weights that vary by breakpoint but all being slender weights (light, ultralight, etc). I specified the fot weight per breakpoint in the extended tags.

Even so, the font always appears in preview and on the site as bold. I can’t remember what the fix is.

Anyone?

Freeway user since 1997

http://www.walterdavisstudio.com

Back to Top

Trey Yancy

20 Jan 2017, 1:48 pm

That’s why they are called “display fonts”. The issue is that I have font sets for the desired weights (“‘RalewayLight’, sans-serif; font-weight: 200” / ‘RalewayUltralight’, sans-serif; font-weight: 100, etc) but the font shows up at about a weight of 400. Everything is set correctly in CSS and HTML.

I hadn’t made any changes, just updating some text and images on a site that’s been up for several years - no fiddling with styles, etc. Simple retyping.

I think I’ll revert to a version from a couple of weeks ago and do it again. Some corruption or something.