FreewayTalk

15 replies to this thread. Most Recent

Jed Rotella

9 Jan 2019, 1:18 am

[Pro] Google Maps

Hello,

I need some help in getting the Google map action to work. The error message I am getting is “the geocode was not successful for the following reason REQUEST_DENIED.

Do I or do I not need an API Key? I believe I got the correct API key.

https://westhillgolfcourse.com/contact1.html there is a map on the map page in the blue box but does not show.

Thanks, Jed

https://westhillgolfcourse.com/contact1.html

Noel Sergeant

13 Jan 2019, 12:22 pm

I’m having the same problem, have you managed to resolve it?

Jed Rotella

13 Jan 2019, 4:44 pm

Good Morning Noel,

No I have not. I have been emailing Softpress back and forth but we have not solved the problem. This is what I have so far. 1-In google maps action I have to put Longitude and latitude in manually it will not generate the correct address on its own. It stays at Oxford England. 2- With my longitude and latitude entered manually and my API key the map shows and works fine when I preview in browser. When I upload to my site there is nothing in the space on the page. There should be my map in the gray box at https://westhillgolfcourse.com/contact.html#nil

Thanks, Jed

Ian Halstead

16 Jan 2019, 9:18 pm

I think it might be an https problem. A website using an SSL certificate won’t show anything that links to an external non-SSL source. The Google Maps action outputs the links as http links, not https.

Check that this is the case by manually altering the link on the page on the server. You can do a search in TextEdit or similar for ‘http’ on the html output for the page and it should find any links that need changing. If the map appears after a change then this is the problem.

It is possible to go into the actual action file and get the code within to always output https links. If you don’t want to do this, there is an https helper action that does this on html output from Freeway.

http://www.actionsforge.com/actions/https-helper

Jed Rotella

28 Jan 2019, 1:16 am

Hi Ian,

I have installed the https helper with no luck on getting the map to work. Any ideas?

Jed

Claas Von rabenau

28 Jan 2019, 10:21 am

Hello Jed, have you considered using the leaflet action?

Cheers Claas

Ian Halstead

28 Jan 2019, 10:40 am

Hi Jed — I’ve taken a quick look at the page html code, and I’m getting errors that indicate that the link to the google map is via an http link, not https. Also for a Twitter link as well. The https-helper action is supposed to sort this out automatically.

I’m not sure where to go from here without either manually changing every instance of ‘http’ to ‘https’ in code on the html pages that Freeway has output — this will need doing every time you output and upload the site. — or alternatively by hacking into the action, not something everyone feels comfortable with. I’m pressed for time at the moment, but I’ll see if I can post a method for doing this at some point.

Ian

Jed Rotella

28 Jan 2019, 1:26 pm

Hello again, I am getting this error message with the leaflet action also. Google maps should be in the gray box on this page. It works in preview mode but not live. I have a screen shot of the error message on my site. Would reinstalling Freeway help?

https://westhillgolfcourse.com/contact.html

Thanks Jed

Jeremy Hughes

28 Jan 2019, 1:36 pm

Hi Jed,

I don’t think reinstalling Freeway will help.

This is one of Walter’s Actions. Does the discussion on ActionsForge help at all?

http://actionsforge.com/actions/leaflet-for-open-street-map

Jeremy

Simon Manning

29 Jan 2019, 9:18 am

Hi Jed,

I can’t say what might have caused the error in the leaflet Action but the Google Maps Action is definitely failing because it’s using http rather than https. Allowing the script to run in the browser anyway (not suggesting that’s a workaround) makes the map show up.

The Facebook Like and Twitter Follow buttons are also in iframes that don’t load because they’re using http rather than https.

In theory HTTPS Helper should deal with all three but the order of Actions can’t be guaranteed, so HTTPS Helper might go first and turn all the http it can find into https, then Google Maps might go after and add an http.

Anyway, the quick and painful fix will be that every time you want to upload your website, you would have to edit your contact page with a text editor (after publishing) and then upload using a separate FTP application.

Alternatively, if you don’t mind the error being there for the time being, you could add the maps script tag (with https) to Page Markup “after <head>”. That would be this:

<script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?key=AIzaSyDPQEWhUSyxfi3DYPEFjIX3w6-D0qNvDyw&amp;sensor=false&amp;language=en"></script>

Note: For anyone else reading, that script tag is specific for Jed’s website as it includes the site key and potentially other options.


The slow(er) and painless fix will be to install an updated Google Maps Action that uses https instead of http, updating Google Maps and other Actions (such as Facebook Like and Twitter Follow) will be quick and easy. We’re figuring out how best to get these and potentially future updates to the standard Actions out to people, without distracting too much from writing the new Freeway.

Simon

Jed Rotella

29 Jan 2019, 1:15 pm

Is there an updated Google Maps action avalible?

David Owen

30 Jan 2019, 4:39 pm

Hi Jed,

You say you installed the HTTPS CDN helper but did you also go the whole hog and apply to each page/s and tick the box in the panel?

On 28 Jan 2019, at 01:16, Jed Rotella <[email protected]> wrote:

I have installed the https helper with no luck on getting the map to work. Any ideas?

David Owen { Freeway Friendly Web hosting and Domains }

http://www.ineedwebhosting.co.uk | http://www.PrintlineAdvertising.co.uk

www.ineedwebhosting.co.uk

Freeway Friendly Web Hosting, Domain Names, VPS and Dedicated Servers. (Create an account it’s Free!)


PrintlineAdvertising.co.uk

Print Design, Digital and Litho Printers, Promotional Merchandise and Corporate Gifts.

David Owen

30 Jan 2019, 4:43 pm

…Sorry my error you were using the https helper action and not the HTTPS CDN helper action. I’ve not used that one.

On 28 Jan 2019, at 01:16, Jed Rotella <[email protected]> wrote:

I have installed the https helper with no luck on getting the map to work. Any ideas?

David Owen { Freeway Friendly Web hosting and Domains }

http://www.ineedwebhosting.co.uk

www.ineedwebhosting.co.uk

Freeway Friendly Web Hosting, Domain Names, VPS and Dedicated Servers. (Create an account it’s Free!)


PrintlineAdvertising.co.uk

Print Design, Digital and Litho Printers, Promotional Merchandise and Corporate Gifts.

Jed Rotella

31 Jan 2019, 1:17 pm

Hello, I followed the above procedure Simon sent me and Google maps is now working. Do you know what I would add to that code to get a marker that says “West Hill Golf Course” ? Thank you for your help Simon!

Jed

Simon Manning

1 Feb 2019, 10:04 am

Hi Jed,

You should be able to do that with the Google Maps Marker Action. Loosely you would draw a layer html item and apply the Google Maps Market Action to it, then in the Action’s settings you can choose the map item and location you want the marker to appear.

Some more information about the Action is on the knowledge base here: https://www.softpress.com/kb/questions/300/

Simon

Back to Top

Simon Manning

7 Mar 2019, 12:30 pm

You can find an updated version of the Google Maps Action on the knowledge base now. Updated Actions will appear on the following knowledge base article unless we decide on a better way of handling updates, in which case that article will be updated to reflect that. https://www.softpress.com/kb/questions/539/Built-in+Action+Updates

Simon