FreewayTalk

2 replies to this thread. Most Recent

Jeremy Hughes

6 Feb 2019, 1:29 pm

Re: [Pro] Mac OS 10.14.3 incompatible message

Just after updating to Mojave 10.14.3, I received a popup message that Freeway Pro 7.1.4 would soon not be compatible with Mac OS system updates. Has anyone else seen this message?

It’s a message that is displayed the first time you run a 32-bit app on Mojave (or maybe on an updated version of Mojave)

Future versions of macOS (after Mojave) are dropping support for 32-bit applications. But Freeway and other 32-bit applications should continue to run on updated versions of Mojave.

Question for the Softpress mods: will there be ongoing updates for Freeway Pro to ensure compatibility with updates beyond 10.14.3?

Yes. We’re working on a 64-bit version of Freeway. Unfortunately, Apple have abandoned many of the (32-bit) APIs that Freeway uses, so we’re rewriting it from scratch. This is a major undertaking, but we’re making good progress.

We’re not at the beta stage yet.

Jeremy

Ian Webb

7 Feb 2019, 11:26 am

This is a major undertaking, but we’re making good progress.

Keep it up Jeremy! We’re all rooting for you and waiting with baited breath!

Ian.

Back to Top

waltd

7 Feb 2019, 1:32 pm

Worms, or cheese?

This homonym has always amused me. You want bated (same root as abate) breath here, methinks.

Walter

On Feb 7, 2019, at 6:26 AM, Ian Webb via freewaytalk <[email protected]> wrote:

baited breath

Freeway user since 1997

http://www.walterdavisstudio.com