FreewayTalk

3 replies to this thread. Most Recent

Zignar

21 Mar 2019, 12:07 pm

Send Form 1.1.1 not sending...

Help

I am trying to set up reCAPTCHA v2 with the latest version of Send Form action (1.1.1). I eventually got the reCAPTCHA to work, (had to generate new keys). However, the form is not sending (I get the error redirection page).

It worked fine with the old PHP feedback form…

What am I doing wrong? Would be grateful for some help!

Sverker

http://www.umeavloppsteknik.se/kontakt.html

Simon Manning

21 Mar 2019, 12:38 pm

This is happening because the reCAPTCHA is outside of the form, so although the reCAPTCHA may be performed, the information from it doesn’t get submitted with the form.

The options to fix this are to include the reCAPTCHA item as part of your form table or to apply the Send Form Action to the page instead of the table. The second option probably makes most sense here because you only have one form on the page and you wouldn’t be able to preserve your current layout with the first option.

Simon

On Thu, Mar 21, 2019 at 12:07 PM Zignar <[email protected]> wrote:

Help

I am trying to set up reCAPTCHA v2 with the latest version of Send Form action (1.1.1). I eventually got the reCAPTCHA to work, (had to generate new keys). However, the form is not sending (I get the error redirection page).

It worked fine with the old PHP feedback form…

What am I doing wrong? Would be grateful for some help!

Sverker

http://www.umeavloppsteknik.se/kontakt.html

Zignar

21 Mar 2019, 1:38 pm

Thanks Simon!

That was it. Seems to work fine now.

Sverker

Back to Top

Zignar

3 Apr 2019, 8:37 am

HELP!

I am trying to implement Google reCAPTCHA v2 with the help of the new Send Form Action (v1.1.1). The reCaptcha works fine, however no messages are being sent!!

https://www.urologiborås.se/kontakt.php

Any suggestions?

Sverker