FreewayTalk

6 replies to this thread. Most Recent

Jamie

21 Sep 2019, 9:35 am

[Pro] FX actions are not working with https?!

Have a look here is the http version:

http://www.tipjarstories.com/fx.html

Here is the https version:

https://www.tipjarstories.com/fx.html

Any thoughts folks?

Gordon Low

21 Sep 2019, 10:17 am

Try applying this action https://actionsforge.com/actions/https-helper

Gordon


Jamie

21 Sep 2019, 4:13 pm

Thanks Gordon. Wasn’t sure this was the answer based on what the action says it does. But tried it and it doesn’t seem to have done the trick. To be honest I don’t think the action is taking (I’m using Freeway 7.1.4) as whilst it downloaded I can’t find it in any other files apart from the downloaded one, or on the Freeway menu options.

Jamie

21 Sep 2019, 4:17 pm

Just to state how I tried to use the action: I downloaded and then clicked on it as I would do previously. Before it would usually find it’s way to the Freeway interface and into a folder in the hard drive.

Jamie

21 Sep 2019, 4:23 pm

Update 2: Freeway seems to recognize that the action exists by stating that it was disabling the second attempt I made to upload it. So I think I can conclude that it is there but does solved the issue.

waltd

21 Sep 2019, 4:25 pm

Actions are installed into your Library/Application Support folder, in the Freeway Pro/Actions folder. This happens automatically when you drag the Action file (recognizable by its .fwaction file extension, or jaunty “cog-f” icon) over the top of the Freeway icon in your Dock, while Freeway is running. You will see a dialog letting you know “you are installing Actions”, and if you okay that, the Action is installed.

If you are going to apply the Action to the page, you first make sure that nothing on the page is selected, either by clicking on the page name in the left pane of Freeway, or by clicking somewhere on the pasteboard, so no page object is selected. Then from the Page/Page Actions menu, you choose the Action to apply it to the page. The Action interface will appear in the Actions palette, which if it is not showing, you can bring into view by choosing the Window / Actions menu item. There is a single check-box in the interface, on by default, that says Use HTTPS Everywhere. There’s really nothing else to do.

Note that this Action will only interact with other Actions that write out their links to libraries using actual tags, not via text substitution. For this reason, it also will not fix any links you have added through the Page / HTML Markup dialogs. Anything like that, that you have written out long-hand (so to speak) is up to you to fix. All you need to do is find all the http://s and replace them with https://s.

I have not tested this extensively, except to use it in my own work. I wrote it a large number of years ago.

Walter

On Sep 21, 2019, at 12:13 PM, Jamie <[email protected]> wrote:

Thanks Gordon. Wasn’t sure this was the answer based on what the action says it does. But tried it and it doesn’t seem to have done the trick. To be honest I don’t think the action is taking (I’m using Freeway 7.1.4) as whilst it downloaded I can’t find it in any other files apart from the downloaded one, or on the Freeway menu options.

Freeway user since 1997

http://www.walterdavisstudio.com

Back to Top

Jamie

22 Sep 2019, 12:18 am

You guys! … What can I say about you guys! The https action was there all along. I was looking for it as an item action. So once I found it (thanks Walter) applied it as normal and voila!

Walter, Gordon, thank you.