Exhibeo

5 replies to this thread. Most Recent

Alvaro de Regil

21 Sep 2020, 4:08 pm

[Pro] Not according to output in most cases

Hi, I bought exhibeo yesterday based on the tests I did using the app. However, when I paste it to freeway the output does not correspond to the behaviour shown in the app.

A specific case in point., the theme I like the most is “Impress”. I tested a set of eight pictures with links. I configured it to slideshow with links.

The first issue is that once you paste it into freeway with the exhibeo action, the slideshow does not work. It remains in the same slide. You have to move to the next manually.

The second issue is that for some reason one of the slides refuses to display the information entered in the captions, even though is the same as the rest, approximate same amount of words, etc.

The third issue is that on preview exhibeo alway moves to the centre, despite the fact that I aligned it to be on the left side of the page.

I tested using both exhibeo pasted into the page and pasted into an html square (inflow: two clicks). But it made no difference.

Would you please help me solve these issues?

Thanks,

Álvaro

Simon Manning

23 Sep 2020, 12:59 pm

Hi Alvaro,

The first and second issues sound like you may have exported your Exhibeo document, then made some changes without exporting again afterwards.

Exporting again from Exhibeo and replacing the previous export should resolve these, though you may also need to select None in the Action, then select your export again.

For the third issue, you should be able to resolve this by placing the Exhibeo item inflow of an HTML item as you’ve tried, but additionally ensuring the HTML item is both left aligned within its parent and won’t grow to 100% width.

You might do this by giving the HTML item a fixed width or a width such as 50%

Simon

Alvaro de Regil

27 Sep 2020, 6:54 pm

Thank you so much for your help Simon.

In fact, I made sure that I had saved my Exhibeo document before exporting it. In any case, I created a new document from scratch, saved it, exported it to FW, and pasted it inflow into an Html item, but the result was the same. When you preview in Safari, Chrome, Firefox and Edge, it renders the “impress” as configured but the slideshow does not work.

The second and third issues did work. Now it is aligned to the left as expected and all the info in the captions is displayed, but the slideshow does not play, so you have to do it manually.

Is there any other reason that you can think as the cause of the problem and how to address it.

Thank you in advance for your help,

Álvaro

Simon Manning

7 Oct 2020, 7:08 pm

Hi Alvaro,

It turns out the slideshow options were missed as part of an overhaul in the way the themes are exported, so they’re not being exported. Thanks for reporting this, I’ve logged it as a bug to be fixed in a future update.

In the meantime, this can be added to your exports fairly easily. Find your export in Finder and ctrl+click, then choose Show Package Contents. Open the body file in TextEdit and scroll to the bottom.

The third line from the bottom should be this:

window.xb_impress(document.scripts[document.scripts.length-1].parentNode.id, {});

The options can be added between the parentheses at the end of that line, so to play a slideshow with 4 seconds between each animation, you would replace that line with this:

window.xb_impress(document.scripts[document.scripts.length-1].parentNode.id, { autoplay: true, interval: 4000 });

Save the file and the next time you publish from Freeway, the slideshow should be working. 4000 is the number of milliseconds between animations, so you can replace this number as desired.

Simon

Alvaro de Regil

7 Oct 2020, 10:52 pm

Hi Simon,

It seems fairly easy. I’m currently working on a partition with Catalina. Tomorrow I will switch to Mojave and try it, but it makes a lot of sense. I will let you know.

Thank you so much,

Álvaro

Back to Top

Alvaro de Regil

10 Oct 2020, 10:22 pm

Hi Simon,

I followed your instructions and everything works as expected. This is great! Thank you so much again.

Álvaro