FreewayTalk

3 replies to this thread. Most Recent

Tony

22 Mar 2021, 1:16 pm

[Pro] Carousel has stoped working

Hello All :)

The Carousel on the pages example above has stoped working. How do I fix this?

The issue is being caused by external scripts coded into the website trying to load over http rather than https, meaning that it won’t load correctly as your site is secure.

An example of this from Chrome’s browser logs show:

Mixed Content: The page at ‘https://tinyurl.com/app/’ was loaded over HTTPS, but requested an insecure script ‘http://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js?load=effects’. This request has been blocked; the content must be served over HTTPS.

This will be because in your website code, it’s set specifically to http rather than https - this would need to be updated on the side the website is built then the new versions uploaded.

Once done, it will load correctly again for you.

https://tinyurl.com/t2j67xep

Any help always appreciated

Tony

Yorkshire | United Kingdom

Freeway Pro 7.1.4

iMac 21.5inc, 16GB | macOS High Sierra 10.13.6

iPhone XS, 256GB | iPhone 7, 32GB | iOS 14.5

waltd

22 Mar 2021, 1:48 pm

There’s two ways to solve this. First, if you’re using Carousel2, there is an update available on ActionsForge that will send all the scripts via https. Universally, there’s another Action you can add to the same page as Carousel (any version) and fix this. https://actionsforge.com/actions/https-cdn-helper

Walter

On Mar 22, 2021, at 9:16 AM, Tony <[email protected]> wrote:

Hello All :)

The Carousel on the pages example above has stoped working. How do I fix this?

The issue is being caused by external scripts coded into the website trying to load over http rather than https, meaning that it won’t load correctly as your site is secure.

An example of this from Chrome’s browser logs show:

Mixed Content: The page at ‘https://tinyurl.com/app/’ was loaded over HTTPS, but requested an insecure script ‘http://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js?load=effects’. This request has been blocked; the content must be served over HTTPS.

This will be because in your website code, it’s set specifically to http rather than https - this would need to be updated on the side the website is built then the new versions uploaded.

Once done, it will load correctly again for you.

https://tinyurl.com/t2j67xep

Freeway user since 1997

http://www.walterdavisstudio.com

Tony

22 Mar 2021, 5:32 pm

Hi Walter

Thank you for your reply.

The https://actionsforge.com/actions/https-cdn-helper was already installed but upon checking this I found that this became unchecked in the Page > Page Actions > menu.

I’ve then rechecked this and ticked the Use HTTPS checkbox.

This is now working as normal.

Thank you for your help once again.

Any help always appreciated

Tony

Yorkshire | United Kingdom

Freeway Pro 7.1.4

iMac 21.5inc, 16GB | macOS High Sierra 10.13.6

iPhone XS, 256GB | iPhone 7, 32GB | iOS 14.5

Back to Top

waltd

22 Mar 2021, 6:11 pm

No problem!

Walter

On Mar 22, 2021, at 1:32 PM, Tony <[email protected]> wrote:

Hi Walter

Thank you for your reply.

The https://actionsforge.com/actions/https-cdn-helper was already installed but upon checking this I found that this became unchecked in the Page > Page Actions > menu.

I’ve then rechecked this and ticked the Use HTTPS checkbox.

This is now working as normal.

Thank you for your help once again.

Freeway user since 1997

http://www.walterdavisstudio.com