Intaglio

18 replies to this thread. Most Recent

Judith Klinger

9 Sep 2010, 1:46 pm

[Pro] Pixel Size of an object

Freeway talks in pixels, Intaglio in points. How can I find out the pixel size of an object? How can I set the pixel size?

AromaCucina: Where home cooking is always in season.

Frank

9 Sep 2010, 3:24 pm

Hi Judith.

Let´s see if this help you out: http://img543.imageshack.us/img543/425/units.jpg

Look under “Layout” for “Measurements” and “Dimensions” and make your changes. To set the pixel size use the “Dimension tool” first and let the object snap while scaling.

Cheers

Frank

Judith Klinger

9 Sep 2010, 5:01 pm

Thanks Frank. I’m sure I’m not explaining my self very clearly. This info seems to apply to text. My problem: I need to make a website button, 140 x 30 pixel size. How do I get the button to be that size…and then how do I export just that object? I’m a newbie…sorry if this is a very elemental question. Grateful for all help! Judith

AromaCucina: Where home cooking is always in season.

Frank

9 Sep 2010, 5:23 pm

After telling Intaglio to use points for measurement use the dimension tool to draw one line of 140points length and one of 30 points. Place and scale you graphic to that size or create a new one within that scale. To export that object select it, go “File” -> “save selection as). Save as “….” and enable “crop to content size”.

http://img259.imageshack.us/img259/2301/dimensions.png

Hope this works for you.

Cheers

Frank

abrax

9 Sep 2010, 8:22 pm

Frank, Do You really get 140x30 pt file then? I’m getting 141 x 31 no matter what I set in the stroke…

Seems that Intaglio will ad at least 1pt to the graphics…

Rafal

pc

9 Sep 2010, 8:40 pm

You are correct, you will usually get a 141x31 sized file. This is because Intaglio uses a VERY conservative algorithm in its “Crop to size” code (which is a REAL pain). You will need to open the file in Photoshop and “Crop” out the extra pixels around the edges. I have found that zooming the graphic very large (in PS) makes this easy, but tedious.

Peter

On Sep 9, 2010, at 1:22 PM, abrax wrote:

Frank, Do You really get 140x30 pt file then? I’m getting 141 x 31 no matter what I set in the stroke…

Seems that Intaglio will ad at least 1pt to the graphics…

Rafal

Frank

9 Sep 2010, 9:03 pm

Yes I got a 140x30 png. The outline is always counting from its center. So everything above zero will be rounded up to the next step. Totally makes sense - at least for me. You can simply subtract 2 points for height+width if you´re going for an 1 point outline in the beginning or don´t use an outline in first place. http://img832.imageshack.us/img832/8152/sizef.png

Cheers

Frank

Judith Klinger

10 Sep 2010, 4:54 pm

Ciao. This all makes sense and I’ve followed these excellent instructions..but I’m still having a problem with the “save as”. Just the button is being saved, but when it comes over to Freeway there is a white box behind it. At first I thought it was because it was an oval button, but it did the same thing with a rectangle. I seem to be bringing over some background part of the object.

Thanks!

AromaCucina: Where home cooking is always in season.

Frank

10 Sep 2010, 7:31 pm

Are you saving to “.png”? You have to to maintain the alpha channel.

Cheers

Frank

abrax

10 Sep 2010, 7:47 pm

Judith -> 1 pixel of white frame rounding a rectangle? …

Frank -> I am still getting +1 pixel image. I don’t know how You do Your magic… :-) Even If I’m not using any outline Intaglio still adds 1 point frame around.

Frank

10 Sep 2010, 8:48 pm

Mmmh. Snapping is on? Just did it as described.

Cheers

Frank

abrax

10 Sep 2010, 10:04 pm

Yes it is on… Intaglio version 3.1.2 …

Here goes an example -> http://img827.imageshack.us/img827/4930/picture1it.png

Frank

10 Sep 2010, 10:44 pm

Strange. Maybe go to “Dimensions” again and turn off “Fractions” and at “Measurements” tell to use points as well. (I didn´t here at least). Hope it will help - otherwise I ran out of hints. ;-)

Cheers

Frank

Judith Klinger

13 Sep 2010, 3:41 pm

Abrax: No, it’s not one pixel all around the image. The button is an oval, but it was contained in a rectangle when i drew the oval. So, somehow I need to delete that background oval, would be my guess.

Frank: I’ve tried it as both a JPEG and PNG and it’s the same problem. thanks, Judith

AromaCucina: Where home cooking is always in season.

Frank

13 Sep 2010, 3:53 pm

JPEGs don´t contain any alphas. Just make sure you haven´t any colored object in the background selected. I made this 140x30px png button and uploaded it. Please check if this is working for you so far. Otherwise a video may help - don´t know. http://img690.imageshack.us/img690/4187/button1wi.png

Cheers

Frank

Judith Klinger

14 Sep 2010, 3:50 pm

Ciao Frank. Thanks for your patience. I don’t have any colored object in the background. Here is an example of what the button looks like, and what happens when I upload it to Freeway. http://img405.imageshack.us/g/screenshot20100914at412.png/

If there is a video avail, I’d love it. Regards and gratitude, Judith

AromaCucina: Where home cooking is always in season.

Frank

14 Sep 2010, 4:39 pm

From what I can tell you´re using a jpg. That won´t work as I stated earlier already: please use “.png” instead to maintain the alpha channel.

Cheers

Frank

Judith Klinger

14 Sep 2010, 5:23 pm

I’ve done both. Didn’t make a difference…yesterday! I just tried it now and it worked!!!! Trying not to get too excited. I’ll report back. :—)

AromaCucina: Where home cooking is always in season.

Back to Top

abrax

14 Sep 2010, 7:28 pm

Works for me too :-)